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General Description
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DG Monitor is a program that connects to an Eaton/Cutler-Hammer Soft-Load Closed-Transfer Transfer Switch or a Peaking Switch and provides a user with the following features:

- Displays real-time power system data (volts, amps, watts and other data)

- Displays both sources (normal and emergency)

- Displays protective relay settings, both for utility and for generator

- Allows changing protective relay settings

- Displays transfer switch timers (TDNE, TDEN, etc.)

- Allows changing transfer switch timers

- Displays status of front panel switches

- Displays alarm status

- Displays speed and voltage bias signals sent from switch to governor and voltage regulator

- Logs data to a "strip chart" display and save data in a format that can be read by a spreadsheet

- Supports direct RS-232 connect or dial-up connection with "auto-find" of transfer switch on any port

Prior to this program, the only way to program a Cutler-Hammer Soft-Load Transfer Switch or Peaking switch was to use the Encorp "NST" program.  The NST software uses the Lonworks communication port on the Transfer Switch.  Since this Lonworks port uses the FT-10, 78 kbps twisted pair, an external converter is required to convert the Lonworks signal to something that could be used with a computer.

This program was written to use the Modbus communication channel built in to each Encorp GPC controller.  The Encorp GPC control is the system used in the Cutler-Hammer Soft-Load Transfer Switches and Peaking Switches.

The benefits of using the Modbus port include:

- Lower cost interface with PC (no external converter required)

- Support for both RS-232 or RS-485 (multi-drop)

- Simple modem interface

- Modbus protocol widely supported by variety of SCADA packages

DG Monitor exploits this simple Modbus protocol interface to provide a full featured program that permits the user to monitor and change most all important settings in the Encorp GPC.

After this opening splash screen is displayed, the program shows the Tip of the DayTopic3.

Installing Program

Place the install CD or Diskette 1 in the computer and select Start -> Run then type in the path to the SETUP.EXE file (usually a:setup.exe if installing from a floppy or d:setup.exe if installing from a CD-ROM.)
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Press OK.

Once the installer start, you will see a message asking if you want to continue the installation.  Select OK.
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Press OK to confirm.

The system will then check to insure that your version of Windows is up to date.  If not, it will ask you if you want to upgrade.  Select YES.  Note that once the program has finished upgrading your system, you will have to restart the SETUP.EXE program.

If, after running the SETUP.EXE a second time the system still asks if you want to upgrade to the latest version of Windows, then you are likely running a system that has security enabled that prevents updating system files.  Contact your system administrator for assistance in upgrading your system files.

Once your system has been confirmed to be at an acceptable revision of Windows, you are presented with this screen.
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If you wish to change the location for the installation of DG Monitor, then press Change Directory.

If the directory shown is acceptable, press the button that looks like a computer (the button just to the left of the text "Click this button to install CH DG Monitoring System....")

You will then be presented with this screen asking you to confirm what "Program Group" you want to install the program.  Unless you have a different group in mind, select the default shown by pressing Continue.
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Press Continue.

Once the installation is complete, you see this message box.  Press OK.
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To start DG Monitor, select Start -> Programs -> Cutler-Hammer -> CH DG Monitoring System
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The system will then present you with a splash screen describing the revision of the program, followed by the Tip of the DayTopic3.

Tip of the Day
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When the program first starts, a "splash" screen is display.  Following the initial "splash" screen the "Tip of the Day" screen is displayed.

After reading the tip, press OK to continue or press Next Tip to scroll through additional tips.

After pressing OK, the program begins to scan Direct Connectionyour computer looking for a Soft-Load Transfer Switch or Peaking Switch connected to any of the installed and available serial ports.

Direct Connection

DG Monitor supports connection to a Soft-Load Transfer Switch or Peaking Switch using a direct RS-232 connection.  DG Monitor supports using any serial port from COM1 through COM8 that is supported by Windows.

The serial cable wiring that you should use is shown hereTopic32.

When DG Monitor first starts, it scans all available serial ports looking for a Transfer Switch or Peaking Switch.  Concurrent with this search, DG Monitor looks for any modem connected to any port.  If you intend to connect to the switch using a modem, refer to those instructionsTopic23.
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If DG Monitor finds a Transfer Switch, it begins communicating directly with the Transfer Switch and terminates the search for modems.

If DG Monitor does not find a Transfer Switch on any available COM port, it presents you with a screen that shows the available COM ports and which COM ports, if any, were found to have modems connected to them.
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If a COM port is listed as "In Use", either another program is using that serial port, or else Windows has listed that port as unavailable.

If the port you intend to use is listed as "In Use", determine what program is using that port (such as a Palm Pilot Hotsync application), and close that competing program.  Once that program is closed, the port should become available, although the status on this screen will not change.  Simply select that COM port and press Continue.

Note: if that other port is not available and you force DG Monitor to use that port anyway, the DG Monitor program will terminate with an error.  Refer to the troubleshooting Topic25section for assistance on determining why you cannot connect.

If the port you have selected is available (no "In Use" message listed next to it) and you have a Soft-Load Transfer Switch connected to it, DG Monitor will begin communication with the Switch and display the Overview StatusTopic9 screen.

Modem Connection

DG Monitor supports connection to a Soft-Load Transfer Switch or Peaking Switch using a dial-up telephone connection.  The modem may be either an internal modem or external modem using any serial port from COM1 through COM8 that is supported by Windows.

Use the cabling shown hereTopic31 to connect the computer running DG Monitor to the Soft-Load Transfer Switch.

When DG Monitor first starts, it scans all available serial ports looking for a Transfer Switch or Peaking Switch.  Concurrent with this search, DG Monitor looks for any modem connected to any port.
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If DG Monitor finds a Transfer Switch, it begins communicating directly with the Transfer Switch and terminates the search for modems.

If DG Monitor does not find a Transfer Switch on any available COM port, it presents you with a screen that shows the available COM ports and which COM ports, if any, were found to have modems connected to them.
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If a COM port is listed as "In Use", either another program is using that serial port, or else Windows has listed that port as unavailable.

If the COM port is listed as "Modem Found - YES", then DG Monitor detected a modem connected to the COM port during its scan of each port.

If you select a COM port that is listed as having a modem, DG Monitor assumes that you wish to dial out to a remote site, so it then prompts you for a telephone number.
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Enter the phone number and include any dial codes (9 to dial out, commas to provide delay between dial, etc.).  For example:

	9
	Dial 9 to get outside line


	,
	Pause (most modems interpret a comma a "wait for 1 second before proceeding" or "wait for 2 seconds before proceeding"


	1 724 773 1203
	Phone number to dial


	1829333293283
	Telephone credit card (note: the three commas preceding this number indicates that we want to delay to wait for the system to prompt for the credit card number


Note that some modems support the 'W' command as "wait for second dial tone", which could be used instead of the three commas if the prompt from the phone system is a second dial tone (or something that sounds sufficiently like a dial tone to be recognized as such by the modem).  In practical applications, just dial the call manually from you telephone handset, note how many seconds before the credit card number is requested, and program in that many commas to provide the same amount of delay.

After pressing OK, the screen changes to display the call progress.
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If the call goes through, you are connected to the remote site and communications proceeds properly (fields behind each value are green).

It is possible that the remote modem will answer, but you cannot communicate with the transfer switch.  Most likely the problem is that the connection between the remote modem and the GPC controller within the switch is disconnected.  Refer to the troubleshooting section for more assistance in determining the problem.

If the remote modem does not answer, or if it answers at other than 9600 baud, this message is displayed.
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Note that these "Last Status" messages are written to the Status MonitorSystem Status screen.  To view this list, go to the Status Monitor screen.

Overview Status Screen

The main Overview Status Screen is divided into 4 sections:

- Overview

- 3 Phase (Protective) Relay (Settings)Topic11
- 1 Phase (Protective) Relay (Settings)Topic12
- Automatic Transfer Switch (Settings) / Other ConfigurationTopic35
- Control Settings

The Overview provides a quick display that shows utility (if transfer switch) and generator voltage, current, Hz, watts and other important electrical data.  Also several status signals are displayed including switch positions, mode of operation and alarm status.
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At the bottom of the screen are two sections:

- Communications

- Other buttons and status (Close and Apply) plus Control Fault and Protective Relay Fault status

The Communications section includes two buttons, a selector and several status indicators.

The Connect button is used to begin communications with a Transfer Switch or Peaking Switch.  If you have reached this screen, likely you will have already connected to the site and have begun communications.

Press Disconnect to stop polling the site.  The Polling / Stopping / Not polling status indicator changes depending on whether the Connect or the Disconnect button was pressed.
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(The Disconnect button was pressed, and the system is in the process of stopping polling).
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The "Not Polling" message confirms that polling has stopped.

The "Last Status" messages show the last status displayed.  These messages display:

- If an error has occurred in reading or writing the GPC controller within the Transfer Switch or Peaking Switch

- If any setpoints in the GPC controller have been changed

- Modem status messages (only if you have selected Extended Error LoggingTopic13 messages).

The "Modem: Disconnected" or "Modem: Connected" is displayed depending on whether you have established a valid dial-up connection to the remote site.  This field is updated every 3 seconds while the program is running.

The "Dial" and "Direct" buttons determine if DG Monitor attempts to dial out to a modemTopic31 or if it is directly connected with an RS-232 cableTopic32 to the GPC controller within the Transfer Switch or Peaking Switch.

The "Update Counter" increments by one every time the screen updates with all new data.  Normally, the screen updates at least once per second.  Dial up telephone lines are slower and will result in a slower update.  Direct connections are faster and will support from 2 to 4 updates per second.

Pressing the Close button closes this screen and returns you to the Main ScreenTopic10.

Pressing the "Changes: Apply" button copies any changes you have made to the GPC settings into non-volatile memory.  If you make changes to the GPC settings, they will remain valid until the next power cycle to the GPC (24 Vdc power cycle).  Once 24 Vdc power is restored, the GPC copies the settings from non-volatile memory back into working memory and begins using those settings.

Therefore, if you want to experiment with different settings but want the ability to revert back to the original settings, do not press the "Changes: Apply" button.

If you do want to make the changes permanent, press the "Changes: Apply" button.

Main Screen

This is the screen that follows the Tip of the Day screen when the Wizard Mode is off.  You can access all the programs features from this screen.
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At the bottom right of the screen are two black dots that periodically flash green to indicate serial data being transmitted from DG Monitor or serial data being received by DG Monitor.

The message "Listen for Incoming Alarms:" displays if DG Monitor is listening to the modem port for an alarm message being sent from the Transfer Switch.  This feature only has meaning if the Transfer Switch is equipped with the optional "Page Out" feature.  Page Out adds an extra controller that monitors the Transfer Switch operation.  Should an event occur that is pre-programmed as an "alarm", the Page Out feature dials two numbers and transmits an alarm.  If one of the numbers is the phone number of the modem connected to DG Monitor, DG Monitor will answer the call and record the alarm message.  This alarm message will cause the bottom display to of the main menu to indicate that an alarm has been received.  To clear this alarm message, press the Acknowledge button.  The Acknowledge button is enabled whenever you are not connected to a Transfer Switch.

The details of the alarm can be viewed from the System Status DisplaySystem Status.

The following functions are available from the main menu:

- Save GPC SetpointsSave Switch (GPC) Setpoints
- Restore GPC SetpointsTopic18
- Save DG Monitor Configuration

- Configure Phone DirectoryTopic14
- Configure Serial PortTopic13
- Exit ProgramExit Direct Connection
- Display System StatusSystem Status
- Connect to Site

- Log Real Time Data to Disk

- Help

Utility Protective Relays

This screen shows the following protective relays:

- Undervoltage (27) / Overvoltage (59)

- Under and Overfrequency (81 O/U)

- Directional Power (32)

- Negative Sequence Overcurrent (Unbalance) (46)

- Negative Sequence Overvoltage (Unbalance) (47)
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The 27/59, 81 and 32 relays include settings for:

- Hi Hi Setpoint

- Hi Setpoint

- Lo Setpoint

- Lo Lo Setpoint

- Hi Hi (or Lo Lo) time delay until trigger (Set Time)

- Hi (or Lo) time delay until trigger (Set Time)

- Hi Hi (or Lo Lo) time delay until reset (Clear Time)

- Hi (or Lo) time delay until reset (Clear Time)

- Deadband for each setting (Hysterisis)

To change a setting, click on the field to be changed and enter a new value, then press the "Save Settings to Transfer Switch" button to send to the GPC controller.

To copy the settings into non-volatile memory, press the Apply button.

For the voltage and frequency relays, the maximum setting is 999 and the minimum is 0.

For the power relay, the maximum setting is 32000 kW (32 MW) and the minimum is -32000 kW (-32 MW).

When this screen is first displayed, the settings are read from the GPC control.  Once the settings are read, the "real-time" values associated with each relay are read continuously.

Next to each relay is a status area that explains if the value is OK or HI or LO.

Generator Protective Relay Settings

Similar to the 3-phase relaysTopic11 and ATS/ConfigTopic35 screens, this screen show real-time values from various single phase protective relays.
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As with the other screen, the settings are only refreshed when:

- The screen is first displayed or

- When you press the "Read Settings from Transfer Switch" button

Likewise, the values you type in for settings are not transmitted to the transfer switch until you press the "Send Settings to Transfer Switch" button.  Only the settings changed on this window are changed.  In other words, if you are showing the 1-phase protective relays, only those settings will be changed by the "Send Settings to Transfer Switch button".

To make the settings permanent (restored even if the 24 Vdc power is cycled to the GPC control), make sure you press the "Changes: Apply" button after you have pressed the Send Settings to Transfer Switch.  This button affects all settings changed from any screen (3-phase, 1-phase or ATS) in the transfer switch.  Therefore, if you make a change on the 3-phase protective relay page, but did not press "Changes: Apply", but later pressed "Changes: Apply" while on the 1-phase protective relay page, the 3-phase (and the 1-phase and all the other) settings would be written into non-volatile memory on the GPC.

ATS Timers, CT/PT Ratios and Configurations

This screen allows you to change:

- 6 separate automatic transfer switch (ATS) timers

- CT and PT ratios for utility (if transfer switch) and generator

- Adjust the voltage and speed bias settings (offset and gain) for the governor and voltage regulator
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ATS Timers

Unlike most of the other fields in DG Monitor, the ATS timers do not accept direct numeric data entry.  Instead, press the up and down arrows next to the field you wish to change.  If you do not have a mouse, or it is inconvenient to use, press the TAB key on the keyboard until either the up or down arrow is flashing next to the timer of interest.  Press the SPACE BAR on the computer keyboard to "press" that button.

CT/PT Ratios

The current transformer (CT) and potential transformer (PT) ratios are multiplying factors that the controller uses to display actual values of current and voltage.  These values will be stamped on the CT or PT.  Usually, PTs will have a primary and a secondary voltage stamped.  The PT ratio is the primary voltage divided by the secondary voltage.

For example, if the primary voltage is 277 volts and the secondary voltage is 120, the ratio is 277/120 = 2.3.  This is the value entered into the PT ratio field on this screen.

Bias

The Soft-Load Transfer Switch sends correcting signals to the engine governor and voltage regulator to adjust the frequency and voltage output to precisely match a desired value.  Since engines are available in different sizes and respond at different speeds to commands, these settings allow the control to be "tuned" to provide better control.

For example, if the gain is set to high, the control will output larger correcting signals in response to a deviation from the desired setting.  If the engine generator receives this large change, it may not be able to response as quickly as could a smaller engine, for example.  If the control sees this lack of action as a need to even further increase the magnitude of the setting change, the engine still can't response immediately.  Eventually the engine will catch up, but by that time the new settings are much too large and the error swings such that the new setting must be reduced by a large amount.

These violent swings are termed "instability" and are typical of too high a gain in the system.  Note that gain can be increased and decreased from this menu, but note that gain is also a setting on the engine governor and voltage regulator.  Make sure those settings are not too high.

As with the other screen, press "Send Settings to Transfer Switch" to write the changes to volatile (temporary) memory on the GPC.  Verify that these settings are correct through testing.  When assured the settings are correct, press the "Changes: Apply" button to copy the settings into non-volatile (permanent) memory.

Serial Port Configuration

DG Monitor auto-configures the serial port for proper operation.  If you wish to change any of these settings manually, select File -> Properties -> Port...
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The Configure Port menu is displayed.  
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	COM Port
	Select COM1 through COM8.

Warning: If you choose to override the selection of serial port by the DG Monitor program, and in the process select an invalid COM port (doesn't exist or is being used), the program will not be able to proceed and will terminate.


	Baud
	Fixed at 9600 with the current version of the Encorp GPC control used within the Soft-Load Transfer Switch and the Peaking Switch


	Parity
	Fixed at N (no) parity with the current version of the Encorp GPC control used within the Soft-Load Transfer Switches and Peaking Switches being built now.


	Update Rate
	Suggested settings
0 ms - Direct RS-232 connection
100 ms - Dial up connection

While dial up telephone modems are labeled as "full-duplex" devices, that is they can talk and listen at the same time, experiments have shown that there is a slight delay in switching the direction of data flow. If you attempt to force messages faster than the modem can "turn around", the message is queued but causes problems.

Increase this delay value to 100 ms to space each message on the network with a minimum of 100 ms of spacing.  This insures sufficient time for the modem to respond and correctly transmit the message.

Do not increase this value any higher than necessary, however, since increasing this delay decreases the number of message per second that can be sent and will cause the response time of the connection to appear more sluggish.


	Wait for Connect
	Amount of time after dialing a phone number before gives up making a connection with a remote site.

45 seconds is the default, but may need to be increased if complex dialing commands, especially those that include many commas (delays) are used.  International calls or credit card calls may also require that you increase this value.


	Timeout
	Amount of time to wait for a response to a message from DG Monitor.  This value becomes active only after you have connected to the Transfer Switch.

Suggested values:
200 ms - when direct connected
500 ms (or more) - when connected by a modem


	Mode - Wizard
	Default

DG Monitor will automatically search for a transfer switch on any port.  If it finds one, it will immediately begin communications.

If it does not find one, but locates a modem connected to one or more of the serial ports, it will report that to the user and request that the user select one of the available COM ports.  If the port selected by the user has a modem, the user is prompted to enter a phone number.  The number is then dialed and a connection is attempted with the remote site.


	Mode - Expert
	DG Monitor will start at the Main Menu and wait for the operator to select an operation.


	Error Logging - Standard
	Default

Limited messages are written to the log (see System Status DisplaySystem Status for more information).
Messages include:
- When program started
- When any setpoint in Transfer Switch was changed
- When an error occurs


	Error Logging - Extended
	Detailed messages are written to the log including:
- All messages from Standard Logging plus
- Modem set up messages
- Additional status message that describe how the program works. Refer to System Status DisplaySystem Status for more information.



If you press the "More >>" key, additional parameters are displayed.  Under normal circumstances, these values will not need to be changed as the affect the intercharacter timing of the individual Modbus message bytes transmitted to the Transfer Switch.  However, for instances when the fastest possible communications with the Transfer Switch is needed, these are the values to adjust.
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	New Character Wait Time
	Direct Connect Default - 20 milliseconds

Modem Connect Default - 100 milliseconds

Amount of time to wait to see if any characters have arrived.  This timer starts after the DG Monitor program has given the characters to be transmitted to Windows.

This time value is necessary to work around Windows' limitations.  Since Windows does not allow a program to directly examine the serial port hardware, we can't be sure how long it takes to send a message out the serial port.  We know when we gave the message to the serial port to be sent, but we don't really know when the last bit of the last byte of the message left the serial port.

We use this delay to free up the computer to do other tasks instead of waiting for new characters.  When the new characters do arrive, we will retrieve them and process them.

Modbus defines an "end of message" as any dead time on the channel that exceeds 3.5 character times.

With a character defined as 8 data bits, 1 stop bit and 1 start bit (10 bits total), 3.5 characters is 3.5 x 10 = 35 bits.

At 9600 bits per second, 35 bits requires 3.6 ms (35/9600), so 20 ms is plenty of time.  However, on a telephone line, sometimes there are delays introduced in the circuit.  In those networks that have longer delays, we wait a longer period of timer after transmitting a message before we expect the first byte of the response to be heard.


	Wait to Purge Receive Buffer
	When the first character is detected in the receive buffer, we wait this amount of time before retrieving the next character.  Normally this will be at least 3.5 character times, but again with a network connection with delay, this value should be increased.

20ms - Direct
100 ms - Dial Up


	Loop Through Buffer Delay
	The program attempts to retrieve characters from the incoming stream as long as the end of the Modbus message hasn't been reached.  Since the end-of-Modbus-message is defined as a break in the character stream of at least 3.5 characters, this value would normally be low.  However, some Modbus slaves place gaps in the reply that exceed the 3.5 characters.  Plus, on modem connections, the delays between each character returned are not as deterministic and therefore a longer delay is needed.

20 ms - Direct
100 ms - Dial Up


Phone Directory

To select the phone directory, select File -> Properties -> Site:
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The Choose Site is then displayed.
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Press the OK button to select the number shown as the new default telephone number to dial.

Press Edit to change the site name or telephone number.

Press Cancel to exit without changing.

Press Configuration -> Save to store this number to disk.

Press Configuration -> Retrieve to read the phone number stored in the disk file.

Note: This version of DG Monitor is limited to support for one telephone number in the directory.

Remember to place commas ',' between any numbers where you wish to insert a pause.  Each comma adds between 1 and 2 seconds of delay on a typical modem.  You will need to experiment to determine the right number of commas to provide the needed delay.

System Status Display

As DG Monitor operates, it logs certain information to a status screen.  This screen can be viewed by selecting View -> Status.
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The System Status Display shows different items depending on whether standard or extended error logging is enabled.  To change the type of error logging, refer to the serial port configurationTopic13 screen.
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Press Close to close this window.  Logging does not stop and queued messages will be displayed when the System Status Display is again opened.

Press Send Ack to transmit an acknowledgement to a Transfer Switch that is configured with "Page Out".  The Page Out option causes the transfer switch to transmit a pager message whenever a transfer switch alarm occurs.  One of the pages can be configured to call this computer.  The message will then be time stamped and displayed on this window.  The Ack button, therefore, only has meaning of the Transfer Switch has the Page Out option installed.

Press Save / Clear to copy all the messages from the window to a spreadsheet file.  The file is written to the same directory where this program was started.  The file name is DGLogmmddyyyyhhmm.csv where:

mm - month

dd - day

yyyy - year

hh - hour

2nd mm - minute

CSV (comma separated variable) file format is readable by Excel.  From inside Excel, select File -> Open, then select under "Files of type", select "Text Files (*.prn, *.txt, *.csv)
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Communication Status

DG Monitor uses a COM port on your computer to communicate with the Transfer Switch or Peaking Switch.  Since it is difficult to know if communications through the serial port is proceeding properly, DG Monitor includes a variety of tools to let you know of a communications problem.

Activity

To know if any activity (with or without error) is occurring through the serial port, refer to the Rx and Tx indicators at the bottom right portion of the main screenTopic10.


[image: image31.png]



Polling and Modem Status

At the bottom of the setpoint monitor screens you will notice a "Communications" window.  This window provides the following status:

- COM port that is being used by DG Monitor (either auto-learned or manually set by user)

- Polling / Stopping / Not Polling Status

- Modem Connected or Disconnected Status

- Update Counter that increments every time the current window completely updates

- Last Status window that provides the last important communications status.
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The Dial and Direct button is selected depending on whether you intend to connect to the Transfer Switch via a direct RS-232 cable or if a dial-out modem is to be used.  If a direct RS-232 cable is used, the Modem: Disconnected status can be ignored.  The "Modem: Disconnected" or "Modem: Connected" status is updated once every 3 seconds and depends on the state of the Data Carrier Detect (DCD) pin on the COM port.  The DCD pin is updated by the modem and is raised high to indicate that the local modem is connected to a remote modem and that the remote modem is transmitting a "carrier".

DG Monitor uses this line to display "Modem: Connected", indicated that DG Monitor has dialed into a remote modem and that the remote modem is connected to your computer.

Intermittent Errors

Occasionally, a message will be received with one or more bits of the message corrupted.  Modbus uses a variety of techniques to determine if a message received is valid.  DG Monitor uses two of the techniques for error checking the message:

1. Calculation of CRC-16 cyclic redundancy check on returned bytes

2. Verify the number of bytes returned matches the number of bytes reported to be returned by the Modbus reply.

Should either of these error checks detect a problem, the value retrieved from the control is not displayed (the previous value is kept), and the background field is changed from a green background to a red background.  This indicates that the latest value retrieved is corrupt and should be ignored.  Refer to the communications troubleshootingTopic36 section for assistance on solving communications problems.
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When a communications error occurs, the "Last Status" message box at the bottom of the screen is updated with the error.  These errors are compiled in a time-stamped list that viewed and saved to an Excel spreadsheet from the View StatusSystem Status screen.

Save GPC Setpoints to Disk

While the complete GPC database includes over 190 setpoints, DG Monitor only displays and allows changing of 120 of the more common settings.  Those 120 settings can be saved to disk by selecting (from the Main Menu) File -> Save GPC Setpoints to File...
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You must have previously connected to the site, otherwise you will be prompted to connect to the site first before attempting to save the setpoints from the remote controller to disk.
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Once connected to the remote site, DG Monitor will read the 120 setpoints from the control, then ask for a filename to store these settings to disk.
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Once the settings are saved to disk, you see this confirmation message.
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Data is written to disk in a text format called Comma Separated Variable (CSV) format.  This format is recognized by Excel.  You can edit the settings in this Excel format and save the settings back as a CSV format for subsequent writing back to the GPC controller within the Transfer Switch.

In this manner, you can prepare a list of setting "offline" without worrying about the necessity of having a controller available to create a temporary database.

Here is a sample screen shot from Excel showing the setpoints stored from DG Monitor.
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You many change any of these settings and then write these values backTopic18 to the transfer switch.  This is how the settings can be modified "off-line" (not connected to a transfer switch).

Restore GPC Setpoints to Transfer Switch

This is the reverse operation of Saving GPC Setpoints to FileSave Switch (GPC) Setpoints.  To restore the previously saved setpoints, select File -> Write File Setpoints to GPC... from the main menuTopic10 of DG Monitor.
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You will then be prompted to select the name of the file that includes the setpoints.
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If the file you select is not a valid setpoint file, this message is displayed.
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If the file you select is valid, then the setpoints are downloaded to the GPC controller.

Note that you will want to test these new settings.  Once you are convinced they are valid, then you will want to copy these settings to non-volatile memory.  To copy the settings to non-volatile memory, select "Changes: Apply" button from the 3-phase relaysTopic11, 1-phase relaysTopic12 or ATS/ConfigTopic35 screen of the connect menu.

Changing Labels Used By DG Monitor

When DG Monitor starts, it reads a file from the directory where DG Monitor started.  This file (labels.csv) contains the cross-reference of Input and Output number to "name" for each I/O point.  This cross-reference is used to determine how the values from the I/O are displayed on the Overview ScreenTopic9.

Here is an example of the data from the default LABELS.CSV file:
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Column A: GPC I/O point name

Column B: How that I/O point is to be displayed on the overview screenTopic9
Column C: Text to display when I/O point is ENERGIZED

Column D: Text to display when I/O point is DE-ENERGIZED

Column E: 1: energized is considered normal; 0: de-energized considered normal

An abnormal (opposite of normal) value is displayed with a yellow background.  A normal value is displayed with a green background.

Exit from a Direct Connection to Transfer Switch

Select File -> Exit from the main menu.  Click hereExit Modem Connection to see how to exit when connected to a modem connection.
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The system will prompt if you are sure.  Select yes.
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The program will close and communications with the Transfer Switch will cease.

Exit from a Modem Connection

The exit procedure is similar to a direct connection exitExit Direct Connection, except that you must be certain that you have disconnected from the remote site before exiting the program.  This is a safety precaution to prevent unintentional toll charges from a telephone that was kept "open", even though the program was terminated.

If you attempt to exit the program without disconnecting first, DG Monitor will alert you that you must disconnect first before you will be allowed to terminate the program.
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Should you wish to terminate DG Monitor without hanging up the connection, use the Windows Task Manager to select DG Monitor and then select "End Task".

Troubleshooting

Non-numeric Entry for Setpoints

When entering values for setpoints such as voltage, frequency or power relays, the values must be valid numbers.  If a non-numeric value is entered, the program will terminate.

Protective Relay Timer Range of Setting

Each protective relay includes a SET and a separate CLEAR timer.  The soft-load transfer switch and the peaking switch support a very wide range of possible settings for these timers ranging from 1 millisecond to 255 days (22 million seconds).

Normally, applications require that these timers be set within a range of 1 to 30 seconds.

DG Monitor software supports displaying timer values (SET and/or CLEAR) for each protective relay in the transfer switch or the peaking switch from 1 second to 15555 seconds (4.32 hours), but it only supports changing a setting if the setting presently stored in the control is less than 127 seconds.

Note that this limitation does not apply to the ATS timers (TDNE, TDEN, TDES, etc.).  DG Monitor displays and permits changing any ATS timer value stored in the controller from 1 second to the maximum allowed.

Display Resolution (Protective Relay Setpoints)

The transfer switch and peaking switch measure voltages and currents and resolve to the nearest 0.01 of a volt or amp internally.

DG Monitor will only display the integer (non-fractional) portion of the value.  For nearly all applications this is appropriate.

Likewise, entering a fractional value for a voltage or current setpoint is transmitted to the switch as an integer.  Any fractional value greater than 0.5 results in the integer portion being incremented by one before being transmitted to the switch.

Reverse Power Relay Settings

The maximum power setting allowed by this version of DG Monitor is 32000 kW (32 MW) for forward power and -32000 kW (-32 MW) for reverse power.  (32-1 and/or 32-2 relays).

While the system will not permit you to enter a value greater than 32000, if the switch already has a value greater than this, it will be displayed incorrectly by DG Monitor (actually values up to 32767 and -32768 stored in the switch will display properly, but you cannot enter a value greater than 32000 or -32000).

Lock Up During Port Scan

During testing of this program, many computers were used to insure that DG Monitor would function under a variety of Windows versions and hardware configurations.  

On one computer tested, COM3 was damaged and would not function.  What we noticed, however, was that Windows reported that the port was available and DG Monitor attempted to use that port to search for a Soft-Load Transfer Switch.  When it did so, Windows hung.  The only solution for recovery was rebooting Windows.

If this occurs, the solution is to tell DG Monitor to not use the "Wizard" interface, but instead use the "Expert" interface.  The Expert mode does not automatically search for a serial port.

To change the mode of operation, locate the file CONFIG.CSV in the DG Monitor directory and open by double-clicking on the file from Windows Explorer.  The file is a text file that can be opened in Notepad, Excel or MS Word (Excel is recommended).

Disable Wizard Mode
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Locate the number to the right of the word "Wizard" and change to 0.  This disables the Wizard Interface.

Note: if the CONFIG.CSV file does not exist in the same directory as the program DGMonitor.EXE, the program will automatically enter the Wizard mode.  If the CONFIG.CSV does not exist, you can create a file in Excel with the entry Wizard in column A and 0 in column B and save the file with the Text format.
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Modem Answers but Cannot Connect to Transfer Switch

	Remote Modem not programmed properly
	The remote modem must be set up to only answer at 9600 baud.  Typically this is fixed by plugging in a computer at the remote modem, enabling a terminal program at 9600 baud, no parity, 8 data bits and 1 stop bit and entering the proper "AT" commands.

To simplify programming the remote modem, DG Monitor includes a mode called "Remote Modem Programming".


	V.92 modem answers, but then hangs up
	A particular property has been observed when a V.92 modem dials to some modems.  The connection is made, but then terminates approximately 10-20 seconds later.  At no time is data transmitted.

The solution is to redial (as many as 30 to 40 times).  The system will eventually connect and from that point on (until power is cycled to the V.92 in the computer running DG Monitor), the system will connect on the first attempt.

Apparently the V.92 standard includes a learning algorithm that may be incompatible some older modems.  The good news is that the V.92 modem learns and eventually configures itself to dial and connect reliably on the first attempt.  Do not cycle power or this learning is lost and will need to be repeated.


	GPC control is disabled
	1.  Make sure the GPC control is powered.
2.  Make sure the GPC is not in watchdog timer trip.  

To determine if the GPC's watchdog timer has tripped, remove the gold cover on the Encorp GPC and observe the plug in "daughter" board.  On the main board near one of the stand-offs for this daughterboard is a green LED.  This LED should be illuminated.  If off, the GPC is in watchdog trip.  While you may be able to communicate, a watchdog trip indicates a serious internal memory corruption or hardware failure that prevents continued operation and this may cause problems with communications.

If the system was operating correctly, then at some later time a watchdog trip occurred, usually cycling power to the GPC will restore a watchdog trip.

If the watchdog trip occurred when downloading a new configuration using the Encorp NST Binding software, cycling power will not restore a watchdog trip.  Usually, the firmware must be "re-flashed" using a Motorola development tool and special software.  Contact Cutler-Hammer for assistance.


No COM Port listed as available

	Other programs are using COM ports
	Close those other programs (Hyperterminal, Palm HotSync, etc.).


	Program crashed without releasing COM port.
Windows assumes port is still unavailable.
	Reboot Windows.


Cannot Exit Program

DG Monitor monitors if it is connected to a remote site by monitoring a signal that tells it if a modem is connected to a remote site.  Under normal circumstances, DG Monitor will always be able to determine if the modem is connected to a remote site.  Under certain circumstances such as:

- DG Monitor program malfunction or

- A user manually changes the port selection to another port after the auto-select function has already selected a port

... DG Monitor may not be able to retrieve the status of the modem connection.

Because the possibility exists of accidentally keeping an expensive long-distance connection open, DG Monitor insists on knowing if the modem is connected to a remote site.  If it cannot determine this, it displays this message.
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If you are certain that the modem has disconnected from the remote site (or never connected in the first place), you may safely terminate this program.

To terminate the program, press <CTRL><ALT><DEL> simultaneously.

In Windows NT, 2000 and XP, select Task Manager, and then select DG Monitor and "End Task".

In Windows 95, 98 and Me, select DG Monitor and "End Task".

Additional Assistance

For assistance with Eaton/Cutler-Hammer Transfer Switches and Peaking Switches, use this contact information:

24-hour emergency support: 800-354-2070

www.ch.cutler-hammer.com

No Communications or Communications Errors

Direct Connection

	1.
	Make sure the cable connection is correct.  Refer to RS-232 wiringTopic32.


	2.
	Make sure the GPC control is set for RS-232 mode.  Refer to the jumpers JP101 - JP107.


	3.
	The RS-232 enabled bit within the controller is disabled.  If this is the problem, you will not be able to communicate (and therefore change) with that bit through the Modbus port.  Instead, you will need to acquire the Encorp NST Config program and connect to the Transfer Switch using a Lonworks adapter (SLTA or PCLTA).  Select the configuration screen that shows the Modbus address and whether the RS-232 port should be enabled.


	4.
	Make sure the COM port in your computer is functional.  Test with another program (Palm Pilot HotSync, etc.)


Modem Connection

	1.
	Verify the cable connection is correct.  Refer to Modem wiringTopic31.


	2.
	Verify that you can connect direct to the Transfer Switch.  Verify each of the items listed under the "Direct Connection" above is set correctly.


	3.
	If the modem answers, but cannot connect, refer to thisTopic24 section for assistance.


Using DG Monitor to Program Remote Modem

(Future)

Using Hyperterminal to Program Remote Modem

These instructions will assume that a USRobotics external Winmodem is used.  Other external modems will work as long as they support the programming necessary to connect at 9600 bits per second.  Most "bargain" external modems do not work at 9600 bits per second.

Connect your computer to the external modem using an "AT modem" cable.  This cable can be purchased at any computer supply store or can be purchased on line from Black Box Corp (www.blackbox.com) as catalog number BC00301.

If you construct or locate your own cable, the cable is built as follows:

	Computer (9-pin male)
	Modem (25-pin male)

	Pin 2  (data in) connects to
	Pin 3 (data out)

	Pin 3  (data out) connects to 
	Pin 2 (data in)

	Pin 5  (common) connects to 
	Pin 7 (common)
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Start Hyperterminal by selecting Start -> Programs -> Accessories -> Communications -> Hyperterminal.

When it starts select any name to use such as "Test".

Select the COM port that you are using to connect to the modem.  Don't worry that the modem isn't listed as one of the choices.  Simply select "Direct to COM1" or "Direct to COM3" or whatever COM port you are using.

Make sure that the settings for that COM port is set to:

9600 baud

No parity

8 data bits

1 stop bit

Select OK and the screen will show a blinking cursor.

Type AT then hit the carriage return.  You should see "OK" returned by the modem.

If you see OK, then you are ready to program the necessary settings to configure the remote modem.

Next type in the following (italicized) entries.

For example type ATZ0 then press the Enter key on the keyboard.  The modem should reply with OK.  Continue with the complete list below.

ATZ0

reset modem

AT&F0

load factory default profile

ATE0

disable local echo

ATF0

disable transmited data echo

ATS0=1

answer on 1st ring

AT&B1

set fixed serial bit rate

AT&D0

ignore DTR hang up

AT&H0

ignore transmit flow control

AT&I0

ignore receive flow control

AT&N6

connect at 9600 bps

AT&R1

modem ignores RTS

AT&U6

min connect speed: 9600 bps

ATY0

power on profile 0 selected

AT&W0

write to NVRAM

Once this list has been programmed, the modem is ready for installation at the remote site.

Modem Wiring

The Encorp GPC controller (Gold Box) cover is removed to expose the small "daughterboard" plugged into the main GPC "motherboard".  On one end of this daughterboard is a terminal strip.

Locate the terminals numbered 79, 77 and 76.  Those terminals will be used to connect to the external modem.

79 - Data Out from GPC to modem

77 - Data In from the modem to the GPC

76 - Signal Common

Make sure the GPC serial port is configured for RS-232 mode.  Set the jumpers as shown below.

Construct a cable as shown in the diagram below that connects Pin 2 of the 25-pin modem connector to terminal 79 of the GPC daughterboard.  Likewise connect Pin 3 of the 25-pin modem connector to terminal 77 of the GPC daughterboard.  Finally, connect Pin 7 of the 25-pin modem connector to terminal 76 of the GPC daughterboard.

Perhaps the easiest method of constructing such a cable is to purchase a pre-made cable with a 25 pin male connector on one end.  Cut off the connector on the other end, strip the insulation off the wires and, using an ohmmeter, determine which wire is associated with pins 2, 3 and 7 on the 25 pin male connector.  You may need a flashlight and magnifying glass to see the numbers on the 25-pin connector, but most have the numbers embossed in the plastic next to each pin.
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The remote modem's serial port must be configured for operation at 9600 bits per second.  To configure the remote modem you can either use a terminal program such as Hyperterminal supplied with Windows, or you can use DG Monitor.

One this wiring is completed, use DG Monitor to dial the remote modem connected to the Soft-Load Transfer Switch and begin communications.  Click hereTopic23 for instructions on how to do that.

RS-232 Wiring

The Encorp GPC controller (Gold Box) cover is removed to expose the small "daughterboard" plugged into the main GPC "motherboard".  On one end of this daughterboard is a terminal strip.

Locate the terminals numbered 79, 77 and 76.  Those terminals will be used to connect to the external modem.

79 - Data Out from GPC to computer

77 - Data In from the computer to the GPC

76 - Signal Common

Make sure the GPC serial port is configured for RS-232 mode.  Set the jumpers as shown on the previous page.

Construct a cable as shown in the diagram below that connects Pin 2 of the 9-pin computer connector to terminal 79 of the GPC daughterboard.  Likewise connect Pin 3 of the 9-pin computer connector to terminal 77 of the GPC daughterboard.  Finally, connect Pin 5 of the 9-pin computer connector to terminal 76 of the GPC daughterboard.

Perhaps the easiest method of constructing such a cable is to purchase a pre-made cable with a 9 pin male connector on one end.  Cut off the connector on the other end, strip the insulation off the wires and, using an ohmmeter, determine which wire is associated with pins 2, 3 and 5 on the 9 pin male connector.  You may need a flashlight and magnifying glass to see the numbers on the 25-pin connector, but most have the numbers embossed in the plastic next to each pin.

Plug the 9-pin connector into any available COM port on the computer (COM1, 2 etc.).  DG Monitor will automatically search all available COM ports for a connected GPC so you don't need to worry about which COM connector you use.

After connecting the computer to the GPC controller, continue with the instructionsDirect Connection for having DG Monitor connect to the Transfer Switch.
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